MPS protocols

From Icbwiki

Jump to: navigation, search

Installation

  1. Download the software from http://www.jetbrains.com/mps/ (this tutorial covers build #320)
  2. Run the installer
  3. Start the MPS application (see Programs menu on Windows).
  4. The Java console will indicate that connection to IDEA could not be established.
  5. Install the plugin (menu-bar->Tools->Install IDEA plugin)
  6. Close MPS program
  7. Start Intellij IDEA (version 6).
  8. Check that MPS plugin is installed (see Plugin Manager)
  9. Start MPS program
  10. The Java console should remain empty until the MPS main window opens. This indicates that the installation of the plugin was succesful.

Test the installation

Jetbrains provides a hello world tutorial. Follow this tutorial to check that MPS can communicate with IDEA.

  1. menu-bar->Help->"Getting started with Jetbrains MPS" will start the tutorial from within MPS.

Bundled examples

MPS is bundled with some examples. To load an example:

  1. menu->File->Open
  2. navigate to the projects directory under the MPS installation directory
  3. Select the .mpr file in the example directory corresponding to the example you want to open.
Personal tools